Frontend Release
Scheduled for Dec 8, 13:00 - 14:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 17, 2021 - 13:38 UTC
Scheduled
We are performing maintenance on the Frontend application to bring you new features and bug fixes. Frontend may not be available during this time, however, your live store will not be affected.
Posted Nov 17, 2021 - 10:43 UTC
This scheduled maintenance affects: Shogun Core Services.